Hi Mimi, On 8/23/21 1:57 PM, Mimi Zohar wrote: > On Mon, 2021-08-23 at 08:14 +0000, THOBY Simon wrote: >> Hi Liqiong, >> >> On 8/23/21 10:06 AM, liqiong wrote: >>> Hi Simon : >>> >>> Using a temporary ima_rules variable is not working for "ima_policy_next". >>> >>> void *ima_policy_next(struct seq_file *m, void *v, loff_t *pos) >>> { >>> struct ima_rule_entry *entry = v; >>> - >>> + struct list_head *ima_rules_tmp = rcu_dereference(ima_rules); >>> rcu_read_lock(); >>> entry = list_entry_rcu(entry->list.next, struct ima_rule_entry, list); >>> rcu_read_unlock(); >>> (*pos)++; >>> >>> - return (&entry->list == ima_rules) ? NULL : entry; >>> + return (&entry->list == ima_rules_tmp) ? NULL : entry; >>> } >>> >>> It seems no way to fix "ima_rules" change within this function, it will alway >>> return a entry if "ima_rules" being changed. >> >> - I think rcu_dereference() should be called inside the RCU read lock >> - Maybe we could cheat with: >> return (&entry->list == &ima_policy_rules || &entry->list == &ima_default_rules) ? NULL : entry; >> as that's the only two rulesets IMA ever use? >> Admittedly, this is not as clean as previously, but it should work too. >> >> The way I see it, the semaphore solution would not work here either, >> as ima_policy_next() is called repeatedly as a seq_file >> (it is set up in ima_fs.c) and we can't control the locking there: >> we cannot lock across the seq_read() call (that cure could end up be >> worse than the disease, deadlock-wise), so I fear we cannot protect >> against a list update while a user is iterating with a lock. >> >> So in both cases a cheat like "&entry->list == &ima_policy_rules || &entry->list == &ima_default_rules" >> maybe need to be considered. >> >> What do you think? > > Is this an overall suggestion or limited to just ima_policy_next()? I was thinking only of ima_policy_next(), I don't think (from what I could see in a short glance) that other functions need such a treatment. The ima_rules_tmp dance is probably safe for the other uses of ima_rules. > > thanks, > > Mimi > > Thanks, Simon