Re: [PATCH v2 01/13] HID: playstation: initial DualSense USB support.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi


I have just a couple minor comments.


2021. január 2., szombat 23:30 keltezéssel, Roderick Colenbrander írta:

> From: Roderick Colenbrander roderick.colenbrander@xxxxxxxx
>
> Implement support for PlayStation DualSense gamepad in USB mode.
> Support features include buttons and sticks, which adhere to the
> Linux gamepad spec.
>
> Signed-off-by: Roderick Colenbrander roderick.colenbrander@xxxxxxxx
> [...]
> +/* Common gamepad buttons across DualShock 3 / 4 and DualSense.
> + * Note: for device with a touchpad, touchpad button is not included
> + *        as it will be part of the touchpad device.
> + */
> +static const int ps_gamepad_buttons[] = {
> +	BTN_WEST, /* Square */
> +	BTN_NORTH, /* Triangle */
> +	BTN_EAST, /* Circle */
> +	BTN_SOUTH, /* Cross */
> +	BTN_TL, /* L1 */
> +	BTN_TR, /* R1 */
> +	BTN_TL2, /* L2 */
> +	BTN_TR2, /* R2 */
> +	BTN_SELECT, /* Create (PS5) / Share (PS4) */
> +	BTN_START, /* Option */
> +	BTN_THUMBL, /* L3 */
> +	BTN_THUMBR, /* R3 */
> +	BTN_MODE, /* PS Home */
> +};
> +
> +static const struct {int x; int y; } ps_gamepad_hat_mapping[] = {
> +	{0, -1}, {1, -1}, {1, 0}, {1, 1}, {0, 1}, {-1, 1}, {-1, 0}, {-1, -1},
> +	{0, 0}
> +};

I believe the preferred way is to have a comma after each array/enum/etc. element
unless it is a terminating entry.


> +
> +static struct input_dev *ps_allocate_input_dev(struct hid_device *hdev, const char *name_suffix)
> +{
> +	struct input_dev *input_dev;
> +
> +	input_dev = devm_input_allocate_device(&hdev->dev);
> +	if (!input_dev)
> +		return ERR_PTR(-ENOMEM);
> +
> +	input_dev->id.bustype = hdev->bus;
> +	input_dev->id.vendor = hdev->vendor;
> +	input_dev->id.product = hdev->product;
> +	input_dev->id.version = hdev->version;
> +	input_dev->uniq = hdev->uniq;
> +
> +	if (name_suffix) {
> +		input_dev->name = devm_kasprintf(&hdev->dev, GFP_KERNEL, "%s %s", hdev->name,
> +				name_suffix);
> +		if (!input_dev->name)
> +			return ERR_PTR(-ENOMEM);
> +	} else {
> +		input_dev->name = hdev->name;
> +	}
> +
> +	input_set_drvdata(input_dev, hdev);
> +
> +	return input_dev;
> +}
> +
> +static struct input_dev *ps_gamepad_create(struct hid_device *hdev)
> +{
> +	struct input_dev *gamepad;
> +	unsigned int i;
> +	int ret;
> +
> +	gamepad = ps_allocate_input_dev(hdev, NULL);
> +	if (IS_ERR(gamepad))
> +		return ERR_PTR(-ENOMEM);

I know that at the moment ENOMEM is the only possible error, but I believe
`return ERR_CAST(gamepad);` would be better. (Or even just `return gamepad;`.)


> +
> +	input_set_abs_params(gamepad, ABS_X, 0, 255, 0, 0);
> +	input_set_abs_params(gamepad, ABS_Y, 0, 255, 0, 0);
> +	input_set_abs_params(gamepad, ABS_Z, 0, 255, 0, 0);
> +	input_set_abs_params(gamepad, ABS_RX, 0, 255, 0, 0);
> +	input_set_abs_params(gamepad, ABS_RY, 0, 255, 0, 0);
> +	input_set_abs_params(gamepad, ABS_RZ, 0, 255, 0, 0);
> +
> +	input_set_abs_params(gamepad, ABS_HAT0X, -1, 1, 0, 0);
> +	input_set_abs_params(gamepad, ABS_HAT0Y, -1, 1, 0, 0);
> +
> +	for (i = 0; i < ARRAY_SIZE(ps_gamepad_buttons); i++)
> +		input_set_capability(gamepad, EV_KEY, ps_gamepad_buttons[i]);
> +
> +	ret = input_register_device(gamepad);
> +	if (ret)
> +		return ERR_PTR(ret);
> +
> +	return gamepad;
> +}
> +
> +static int dualsense_parse_report(struct ps_device *ps_dev, struct hid_report *report,
> +		u8 *data, int size)
> +{
> +	struct hid_device *hdev = ps_dev->hdev;
> +	struct dualsense *ds = container_of(ps_dev, struct dualsense, base);
> +	struct dualsense_input_report *ds_report;
> +	uint8_t value;
> +

I think `size` should be checked somewhere around here.


> +	/* DualSense in USB uses the full HID report for reportID 1, but
> +	 * Bluetooth uses a minimal HID report for reportID 1 and reports
> +	 * the full report using reportID 49.
> +	 */
> +	if (report->id == DS_INPUT_REPORT_USB && hdev->bus == BUS_USB) {
> +		ds_report = (struct dualsense_input_report *)&data[1];
> +	} else {
> +		hid_err(hdev, "Unhandled reportID=%d\n", report->id);
> +		return -1;
> +	}
> +
> +	input_report_abs(ds->gamepad, ABS_X,  ds_report->x);
> +	input_report_abs(ds->gamepad, ABS_Y,  ds_report->y);
> +	input_report_abs(ds->gamepad, ABS_RX, ds_report->rx);
> +	input_report_abs(ds->gamepad, ABS_RY, ds_report->ry);
> +	input_report_abs(ds->gamepad, ABS_Z,  ds_report->z);
> +	input_report_abs(ds->gamepad, ABS_RZ, ds_report->rz);
> +
> +	value = ds_report->buttons[0] & DS_BUTTONS0_HAT_SWITCH;
> +	if (value > 7)
> +		value = 8; /* center */

This seems a bit flimsy to me, it relies on a different part of the code
being in a certain way that is not enforced by anything. I'd probably do something
like this:

enum {
  HAT_DIR_W = 0,
  HAT_DIR_NW,
  ...
  HAT_DIR_SW,
  HAT_DIR_NONE,
};

static const struct {int x; int y; } ps_gamepad_hat_mapping[] = {
  [HAT_DIR_W] = {0, -1},
  ...
  [HAT_DIR_NONE] = {0, 0},
};

and then

if (value >= ARRAY_SIZE(ps_gamepad_hat_mapping))
  value = HAT_DIR_NONE;

Please consider it. By the way, are values 9..15 actually sent by the controller?


> +	input_report_abs(ds->gamepad, ABS_HAT0X, ps_gamepad_hat_mapping[value].x);
> +	input_report_abs(ds->gamepad, ABS_HAT0Y, ps_gamepad_hat_mapping[value].y);
> +
> +	input_report_key(ds->gamepad, BTN_WEST,   ds_report->buttons[0] & DS_BUTTONS0_SQUARE);
> +	input_report_key(ds->gamepad, BTN_SOUTH,  ds_report->buttons[0] & DS_BUTTONS0_CROSS);
> +	input_report_key(ds->gamepad, BTN_EAST,   ds_report->buttons[0] & DS_BUTTONS0_CIRCLE);
> +	input_report_key(ds->gamepad, BTN_NORTH,  ds_report->buttons[0] & DS_BUTTONS0_TRIANGLE);
> +	input_report_key(ds->gamepad, BTN_TL,     ds_report->buttons[1] & DS_BUTTONS1_L1);
> +	input_report_key(ds->gamepad, BTN_TR,     ds_report->buttons[1] & DS_BUTTONS1_R1);
> +	input_report_key(ds->gamepad, BTN_TL2,    ds_report->buttons[1] & DS_BUTTONS1_L2);
> +	input_report_key(ds->gamepad, BTN_TR2,    ds_report->buttons[1] & DS_BUTTONS1_R2);
> +	input_report_key(ds->gamepad, BTN_SELECT, ds_report->buttons[1] & DS_BUTTONS1_CREATE);
> +	input_report_key(ds->gamepad, BTN_START,  ds_report->buttons[1] & DS_BUTTONS1_OPTIONS);
> +	input_report_key(ds->gamepad, BTN_THUMBL, ds_report->buttons[1] & DS_BUTTONS1_L3);
> +	input_report_key(ds->gamepad, BTN_THUMBR, ds_report->buttons[1] & DS_BUTTONS1_R3);
> +	input_report_key(ds->gamepad, BTN_MODE,   ds_report->buttons[2] & DS_BUTTONS2_PS_HOME);
> +	input_sync(ds->gamepad);
> +
> +	return 0;
> +}
> +
> +static struct ps_device *dualsense_create(struct hid_device *hdev)
> +{
> +	struct dualsense *ds;
> +	int ret;
> +
> +	ds = devm_kzalloc(&hdev->dev, sizeof(*ds), GFP_KERNEL);
> +	if (!ds)
> +		return ERR_PTR(-ENOMEM);
> +
> +	/* Patch version to allow userspace to distinguish between
> +	 * hid-generic vs hid-playstation axis and button mapping.
> +	 */
> +	hdev->version |= HID_PLAYSTATION_VERSION_PATCH;
> +
> +	ds->base.hdev = hdev;
> +	ds->base.parse_report = dualsense_parse_report;
> +	hid_set_drvdata(hdev, ds);
> +
> +	ds->gamepad = ps_gamepad_create(hdev);
> +	if (IS_ERR(ds->gamepad)) {
> +		ret = PTR_ERR(ds->gamepad);
> +		goto err;
> +	}
> +
> +	return &ds->base;
> +
> +err:
> +	return ERR_PTR(ret);
> +}
> [...]
> +static int ps_probe(struct hid_device *hdev, const struct hid_device_id *id)
> +{
> +	struct ps_device *dev;
> +	int ret;
> +
> +	ret = hid_parse(hdev);
> +	if (ret) {
> +		hid_err(hdev, "parse failed\n");
> +		return ret;
> +	}
> +
> +	ret = hid_hw_start(hdev, HID_CONNECT_HIDRAW);
> +	if (ret) {
> +		hid_err(hdev, "hw start failed\n");
> +		return ret;
> +	}
> +
> +	ret = hid_hw_open(hdev);
> +	if (ret) {
> +		hid_err(hdev, "hw open failed\n");
> +		goto err_stop;
> +	}
> +
> +	if (hdev->product == USB_DEVICE_ID_SONY_PS5_CONTROLLER) {

I'm still not fully seeing the purpose of this `if`. The probe should not be
called for devices not in the id_table, so this seems to me to be a long way
of writing `if (true)`. Or am I missing something?


> +		dev = dualsense_create(hdev);
> +		if (IS_ERR(dev)) {
> +			hid_err(hdev, "Failed to create dualsense.\n");

I think it'd be preferable if all log messages would either be lowercase or
uppercase, not a mix of both. Same for punctuation. This applies to all patches.


> +			ret = PTR_ERR(dev);
> +			goto err_close;
> +		}
> +	}
> +
> +	return ret;
> +
> +err_close:
> +	hid_hw_close(hdev);
> +err_stop:
> +	hid_hw_stop(hdev);
> +	return ret;
> +}
> [...]


Regards,
Barnabás Pőcze




[Index of Archives]     [Linux Media Devel]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Linux Wireless Networking]     [Linux Omap]

  Powered by Linux