On Thu, 10 Nov 2016, hn.chen@xxxxxxxxxxxxxxx wrote: > From: HungNien Chen <hn.chen@xxxxxxxxxxxxxxx> > > Rename i2c_hid_blacklist as i2c_hid_quirks. > Make the syntax changes of macro & for_loop slightly. > > Signed-off-by: HungNien Chen <hn.chen@xxxxxxxxxxxxxxx> > --- > drivers/hid/hid-ids.h | 5 ++++ > drivers/hid/i2c-hid/i2c-hid.c | 57 +++++++++++++++++++++++++++++++++++++++++++ > 2 files changed, 62 insertions(+) > > diff --git a/drivers/hid/hid-ids.h b/drivers/hid/hid-ids.h > index 6cfb5ca..787afdf 100644 > --- a/drivers/hid/hid-ids.h > +++ b/drivers/hid/hid-ids.h > @@ -1033,6 +1033,11 @@ > #define USB_DEVICE_ID_WALTOP_MEDIA_TABLET_14_1_INCH 0x0500 > #define USB_DEVICE_ID_WALTOP_SIRIUS_BATTERY_FREE_TABLET 0x0502 > > +#define USB_VENDOR_ID_WEIDA 0x2575 > +#define USB_DEVICE_ID_WEIDA_8756 0x8756 The patch looks good to me now, thanks for incorporating all the feedback. My only remaining question -- why is 0x8756 being added into hid-ids.h, but then not actually used for defining a quirk? -- Jiri Kosina SUSE Labs -- To unsubscribe from this list: send the line "unsubscribe linux-input" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html