Re: [PATCH] input: add support for PowerOn(PonKey) button on the AB8500 MFD

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Sundar,

> +
> +	info->idev->name = "AB8500 POn(PowerOn) Key";

nit-pick: having spaces in the name would create hard time parsing it. Though it all
depends on the userspace framework.

> +
> +static struct platform_driver ab8500_ponkey_driver = {
> +	.driver		= {
> +		.name	= "ab8500-poweron-key",
> +		.owner	= THIS_MODULE,
> +	},
> +	.probe		= ab8500_ponkey_probe,
> +	.remove		= __devexit_p(ab8500_ponkey_remove),

It is not must for this driver to go through, but what would be the behaviour of
pwr-key on suspend and resume? Do you want power key to wakeup the system from sleep?
OR don't want to make it as wakeup source?

---Trilok Soni

-- 
Sent by a consultant of the Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum.
--
To unsubscribe from this list: send the line "unsubscribe linux-input" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Media Devel]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Linux Wireless Networking]     [Linux Omap]

  Powered by Linux