[PATCH 07/31] Some dracut cleanups and bashification.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Get rid of `` subprocess expansion when killing udevd.

$() subprocess expansion is so much easier to read.
---
 init |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/init b/init
index 2b7aa36..599f8ad 100755
--- a/init
+++ b/init
@@ -101,7 +101,7 @@ if [ -x $NEWROOT/usr/sbin/load_policy ]; then
 fi
 
 # kill off udev
-kill `pidof udevd`
+kill $(pidof udevd)
 
 [ -x /bin/plymouth ] && plymouth --newroot=$NEWROOT
 
-- 
1.6.0.6

--
To unsubscribe from this list: send the line "unsubscribe initramfs" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Kernel]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux SCSI]

  Powered by Linux