On 12/13/24 10:44 AM, Antoniu Miclaus wrote: > Add support for the AD485X a fully buffered, 8-channel simultaneous > sampling, 16/20-bit, 1 MSPS data acquisition system (DAS) with > differential, wide common-mode range inputs. > > Signed-off-by: Antoniu Miclaus <antoniu.miclaus@xxxxxxxxxx> > --- > changes in v8: > - fix kernel bot warnings. > - drop optional members from chip info struct > - drop final line continuation > - drop ext_scan_type and num_ext_scan_type duplicate set. > - create common function for parsing channels to avoid code duplication. > - add comment for fields not set in the parts chip info struct. > - add safety margin for pwm duty cycle. > - use FIELD_PREP where indicated. > - use chip resolution instead of chan->scan_type.realbits where indicated. > - move the reset procedure before setting refbuf/refsel registers. > - use iio_get_current_scan_type where indicated. > - refull and compute scales if osr is changed. > - take into account the osr for the sampling frequency. > - drop num_channels division by 2 which remained from v6. > - drop ad4851_scan_type_16 since it is not used. > - change sign based on diff in iio channel definition. > - shrink same register writes into a single operation. I'm a bit confused on what the intention is now. In v7, diff-channels was added to the DT bindings but in v8 it was removed again. Did you change your mind internally again? Or is the intention still to specify single-ended/differential in the devicetree? It really helps reviewers if you include a cover letter and explain the reasoning behind big changes like this. Otherwise we are left guessing.