The aim of this serie is to add scaling support to STM32 DFSDM peripheral in the analog context. The DFSDM currently operates as a consumer of IIO channels provided by a generic SD modulator. As previously discussed in RFC [1], this topology is not suitable for implementing scaling. This series brings the integration of the DFSDM driver with the new IIO backend framework [2], enabling the DFSDM IIO device to offer scaling feature based on reference voltage data obtained from the IIO SD modulator backend. This generic SD modulator backend takes the place of the former SD modulator, used with legacy implementation. The DFSDM driver has been updated to adopt the generic ADC channel binding [3]. The reasons for this include: - Reducing the use of proprietary properties - Simplifying the coexistence of legacy and new backend bindings - Prepare the support of the MDF peripheral on STM32MP25 SoC Backward compatibility is maintained through legacy support. This series extends the backend framework with the following APIs: - iio_backend_read_raw: This API is intented to retrieve the voltage information from the backend. It is based on IIO framework read_raw API. - iio_backend_disable / iio_backend_enable: backend enable/disable to be used for PM management - devm_iio_backend_fwnode_get Intended for parsing DT subnodes to allow generic channel binding support, as generic channel DT nodes are not populated as devices. [1]: https://lore.kernel.org/lkml/20200204101008.11411-1-olivier.moysan@xxxxxx/ [2]: https://lore.kernel.org/all/20240206-iio-backend-v9-0-df66d159c000@xxxxxxxxxx/ [3]: devicetree/bindings/iio/adc/adc.yaml Changes in v2: - Update enable/disable backend API - Rename devm_iio_backend_subnode_get(), as devm_iio_backend_fwnode_get() - Update iio_backend_read_raw() prototype to fully match IIO framework read_raw callback prototype. - Change st,adc-channel-type property name and type in DFSDM binding - Remove sd-backend and rename ads1201 compatibles in SD binding Conor, in this v2, I left the SD modulator driver & binding unchanged, regarding the naming issue you raised previously. The problem here is that we have two versions of the generic sigma delta modulator driver: one for legacy support and a new one to support new binding. Maybe an alternate, is to rename former sd modulator as "legacy" or something similar. I will address this point in a v3 if necessary. Olivier Moysan (8): iio: add read raw service to iio backend framework iio: add enable and disable services to iio backend framework iio: add child nodes support in iio backend framework dt-bindings: iio: dfsdm: move to backend framework dt-bindings: iio: add sigma delta modulator backend iio: adc: stm32-dfsdm: adopt generic channels bindings iio: add sd modulator generic iio backend iio: adc: stm32-dfsdm: add scaling support to dfsdm .../iio/adc/sd-modulator-backend.yaml | 39 +++ .../bindings/iio/adc/st,stm32-dfsdm-adc.yaml | 157 ++++++++- drivers/iio/adc/Kconfig | 11 + drivers/iio/adc/Makefile | 1 + drivers/iio/adc/sd_adc_backend.c | 117 +++++++ drivers/iio/adc/stm32-dfsdm-adc.c | 302 +++++++++++++++--- drivers/iio/industrialio-backend.c | 108 +++++-- include/linux/iio/backend.h | 10 +- 8 files changed, 679 insertions(+), 66 deletions(-) create mode 100644 Documentation/devicetree/bindings/iio/adc/sd-modulator-backend.yaml create mode 100644 drivers/iio/adc/sd_adc_backend.c base-commit: 2dfa1b7bfc07e58acb9f9eaa8c871f37189dbfee -- 2.25.1