On Tue, 2024-04-23 at 18:50 +0300, Andy Shevchenko wrote: > On Tue, Apr 23, 2024 at 05:20:33PM +0200, Nuno Sa via B4 Relay wrote: > > From: Nuno Sa <nuno.sa@xxxxxxxxxx> > > > > Make use of dev_err_probe() and dev_err_ptr_probe() to simplify error paths > > during probe. > > ... > > > + return dev_err_ptr_probe(&iiodev->dev, ret, > > + "Error in registering sensor update > > notifier for sensor %s err %d", > > \n sure... > > > + sensor->sensor_info->name, ret); > > ... > > > + return dev_err_probe(dev, -EINVAL, > > + "SCMI sensor %d has missing > > info\n", i); > > One line? (It's 99 if you use relaxed limit). Being this IIO, Jonathan prefers to stick the old limit unless readability is hurt... > > ... > > > + return dev_err_probe(dev, PTR_ERR(scmi_iio_dev), > > + "failed to allocate IIO device for > > sensor %s: %ld\n", > > + sensor_info->name, > > PTR_ERR(scmi_iio_dev)); > > Please, be sure you remove double error code printing, dev_err_probe() does it > for you already. (This applies to all places like this, if any, in the entire > series.) Up... blind conversion. Thanks! - Nuno Sá