On Sat, 2024-04-06 at 17:07 +0100, Jonathan Cameron wrote: > On Thu, 4 Apr 2024 18:12:25 +0300 > Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> wrote: > > > On Thu, Apr 04, 2024 at 04:58:27PM +0200, Nuno Sá wrote: > > > On Thu, 2024-04-04 at 15:23 +0300, Andy Shevchenko wrote: > > > > On Thu, Apr 04, 2024 at 01:06:25PM +0200, Nuno Sa wrote: > > > > > Using dev_errp_probe() to simplify the code. > > > > ... > > > > > > > + if (IS_ERR(fwnode)) > > > > > + return dev_errp_probe(dev, PTR_ERR(fwnode), > > > > > + "Cannot get Firmware > > > > > reference\n"); > > > > > > > > ERR_CAST() seems quite good candidate to have here. > > > > > > > > return dev_errp_probe(dev, fwnode, "Cannot get Firmware > > > > reference\n"); > > > > > > > > (Assuming dev_errp_probe() magically understands that, note you may have > > > > it as > > > > a macro and distinguish parameter type with _Generic() or so and behave > > > > differently: ERR_PTR() vs. ERR_CAST(), see acpi_dev_hid_uid_match() > > > > implementation, but also keep in mind that it doesn't distinguish > > > > NULL/0, > > > > there > > > > is a patch available in the mailing list to fix that, though.) > > > > > > Do we care that much for going with that trouble? > > > > I don't think we do. We are not supposed to be called with ret == 0/NULL. > > That's why I pointed out to the current version. > > > > > I understand like this we go > > > PTR_ERR() to then comeback to ERR_PTR() but this for probe() which is not > > > a > > > fastpath. So perhaps we could just keep it simple? > > > > It's not about performance, it's about readability. See the difference > > between > > yours and mine. > > > > You are suggesting making it transparently take an error ptr or an integer? > Whilst clever, I'm not seeing that as a good idea for readability / > reviewability. > I expect something that looks like a function to take the same parameters > (other vargs) > always. _Generic messes with that. > Maybe I just don't like to learn new things! If consensus comes down in > favour > of _Generic trickery then I'll get used to it eventually. > Yeah, I agree with the above. Not fully convinced but for the ERR_CAST() case I would very much prefer to have another explicit helper rather than hiding stuff in the same macro. - Nuno Sá