Re: [PATCH v14 2/3] iio: adc: ad_sigma_delta: Add optional irq selection

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Thu, Feb 22, 2024 at 01:07:42PM +0200, Dumitru Ceclan wrote:
> Add optional irq_num attribute to ad_sigma_delta_info structure for
> selecting the used interrupt line for adc's conversion completion.



> + * @irq_num: IRQ for reading conversions. If 0, spi->irq will be used

Naming is a bit confusing. Does _num mean the amount of IRQ vectors?
Perhaps irq_line, irq_conv?


> +	unsigned long irq_num;

Why is it not simple (signed) int?


> +	unsigned int		irq_num;


With Best Regards,
Andy Shevchenko

[Index of Archives]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Input]     [Linux Kernel]     [Linux SCSI]     []

  Powered by Linux