Hi Jonathan, Thank you for all comments to this set. Will do the changes and send v4. Thanks, Marcelo On 12/10, Jonathan Cameron wrote: > On Thu, 7 Dec 2023 15:42:56 -0300 > Marcelo Schmitt <marcelo.schmitt@xxxxxxxxxx> wrote: > > > Add support for Analog Devices AD7091R-2, AD7091R-4, and AD7091R-8 > > low power 12-Bit SAR ADCs with SPI interface. > > Extend ad7091r-base driver so it can be used by the AD7091R-8 driver. > > > > Signed-off-by: Marcelo Schmitt <marcelo.schmitt@xxxxxxxxxx> > > A few trivial things inline. > Otherwise looks pretty good to me. > > Jonathan > > diff --git a/drivers/iio/adc/ad7091r8.c b/drivers/iio/adc/ad7091r8.c > > new file mode 100644 > > index 000000000000..8dc0f784913b > > --- /dev/null > > +++ b/drivers/iio/adc/ad7091r8.c > > @@ -0,0 +1,261 @@ > > +// SPDX-License-Identifier: GPL-2.0 > > +/* > > + * Analog Devices AD7091R8 12-bit SAR ADC driver > > + * > > + * Copyright 2023 Analog Devices Inc. > > + */ > > + > > +#include <linux/bitfield.h> > > +#include <linux/iio/iio.h> > > +#include <linux/module.h> > > +#include <linux/regmap.h> > > +#include <linux/gpio/consumer.h> > > +#include <linux/spi/spi.h> > > + > > +#include "ad7091r-base.h" > > + > > +#define AD7091R8_REG_ADDR_MSK GENMASK(15, 11) > > +#define AD7091R8_RD_WR_FLAG_MSK BIT(10) > > +#define AD7091R8_REG_DATA_MSK GENMASK(9, 0) > > + > > +#define AD7091R2_DEV_NAME "ad7091r-2" > > +#define AD7091R4_DEV_NAME "ad7091r-4" > > +#define AD7091R8_DEV_NAME "ad7091r-8" > Not seeing any advantage in these macros. It will be more readable to just > have the strings inline where the macros are currently used. > > > +static int ad7091r8_gpio_setup(struct ad7091r_state *st) > > +{ > > + st->convst_gpio = devm_gpiod_get(st->dev, "adi,conversion-start", > > + GPIOD_OUT_LOW); > > + if (IS_ERR(st->convst_gpio)) > > + return dev_err_probe(st->dev, PTR_ERR(st->convst_gpio), > > + "Error getting convst GPIO\n"); > > + > > + st->reset_gpio = devm_gpiod_get_optional(st->dev, "reset", > > + GPIOD_OUT_HIGH); > > + if (IS_ERR(st->reset_gpio)) > > + return PTR_ERR(st->reset_gpio); > Maybe a dev_err_probe() here as well both for consistency and for the > debug info that gets stashed if it's EPROBE_DEFER > > + > > + if (st->reset_gpio) { > > + fsleep(20); > > + gpiod_set_value_cansleep(st->reset_gpio, 0); > > + } > > + > > + return 0; > > +} > > > + > > +static struct ad7091r_init_info ad7091r2_init_info = { > > + .info_no_irq = AD7091R_SPI_CHIP_INFO(2), > > + .regmap_config = &ad7091r2_reg_conf, > > + .ad7091r_regmap_init = &ad7091r8_regmap_init, > > + .ad7091r_setup = &ad7091r8_gpio_setup > > +}; > > + > > +static struct ad7091r_init_info ad7091r4_init_info = { > > + .irq_info = AD7091R_SPI_CHIP_INFO_IRQ(4), > > + .info_no_irq = AD7091R_SPI_CHIP_INFO(4), > > + .regmap_config = &ad7091r4_reg_conf, > > + .ad7091r_regmap_init = &ad7091r8_regmap_init, > > + .ad7091r_setup = &ad7091r8_gpio_setup > > +}; > > + > > +static struct ad7091r_init_info ad7091r8_init_info = { > > + .irq_info = AD7091R_SPI_CHIP_INFO_IRQ(8), > > + .info_no_irq = AD7091R_SPI_CHIP_INFO(8), > > + .regmap_config = &ad7091r8_reg_conf, > > + .ad7091r_regmap_init = &ad7091r8_regmap_init, > > + .ad7091r_setup = &ad7091r8_gpio_setup > > +}; > > + > > +static int ad7091r8_spi_probe(struct spi_device *spi) > > +{ > > + const struct spi_device_id *id = spi_get_device_id(spi); > > + const struct ad7091r_init_info *init_info; > > + > > + init_info = spi_get_device_match_data(spi); > > + if (!init_info) > > + return -EINVAL; > > + > > + return ad7091r_probe(&spi->dev, id->name, init_info, NULL, spi->irq); > id->name isn't generally a good idea because we end up with lots of odd corner > cases if the of_device_id and spi_device_id tables get out of sync - which > can happen if fallback compatibles get used. > > Normal way round this is just put the naming of the device in the > info structure. Costs a little storage, but makes the code simpler > and less probe to odd corner cases. Also, I think you already have it > in there! > > > +} > > + > > +static const struct of_device_id ad7091r8_of_match[] = { > > + { .compatible = "adi,ad7091r2", .data = &ad7091r2_init_info }, > > + { .compatible = "adi,ad7091r4", .data = &ad7091r4_init_info }, > > + { .compatible = "adi,ad7091r8", .data = &ad7091r8_init_info }, > > + { } > > +}; > > +MODULE_DEVICE_TABLE(of, ad7091r8_of_match); > > + > > +static const struct spi_device_id ad7091r8_spi_id[] = { > > + { "ad7091r2", (kernel_ulong_t)&ad7091r2_init_info }, > > + { "ad7091r4", (kernel_ulong_t)&ad7091r4_init_info }, > > + { "ad7091r8", (kernel_ulong_t)&ad7091r8_init_info }, > > + {} > Trivial but be consistent on spacing for these terminators. I like a space, so > { } but I don't mind if an author prefers {} as long as they are consistent! > > > +}; > > +MODULE_DEVICE_TABLE(spi, ad7091r8_spi_id); >