On Tue, Apr 04, 2023 at 10:12:00AM -0400, William Breathitt Gray wrote: > By bailing out early if chan->output is false for the IIO_CHAN_INFO_RAW, > indentation can be decreased by a tab and code readability improved. ... > + /* DAC can only accept up to a 16-bit value */ > + if ((unsigned int)val > 65535) > + return -EINVAL; While the patch is good per se, I don't like two things (which are also in the original code): - explicit casting (can it be avoided?) - would be good to have U16_MAX or ?.. instead of hard coded number Can it be addressed with (additional) patches? -- With Best Regards, Andy Shevchenko