On Mon, Mar 20, 2023 at 09:50:35AM +0100, Johannes Berg wrote: > On Sat, 2023-03-18 at 14:59 +0000, William Breathitt Gray wrote: > > It is a common code pattern to modify a bitfield by masking the field > > and performing a bitwise OR with the respective FIELD_PREP. Wrap such a > > task into a macro by introducing FIELD_MODIFY() which modifies the field > > specified by a mask from a bitfield by putting a val in the field. > > So I have no objection to adding this and you using FIELD_* macros, but > just wanted to say that personally I've come to prefer the typed > versions declared later in the fiel, and there we have > <type>_replace_bits() already. > > Hmm. And now that I mentioned that, maybe that means FIELD_REPLACE() > would be nicer as a name? > > johannes Perhaps I can convert all of these FIELD_GET(), FIELD_MODIFY(), and FIELD_GET() to the equivalent of u8_get_bits(), u8p_replace_bits(), and u8_encode_bits(). If that works, then I'll just drop the FIELD_MODIFY() patch in the v2 patchset submission. William Breathitt Gray
Attachment:
signature.asc
Description: PGP signature