Re: [PATCH v2 1/1] iio: adc: qcom-spmi-adc5: Fix the channel name

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 2023-01-18 15:22:42, Andy Shevchenko wrote:
...
> > > +	name = devm_kasprintf(dev, GFP_KERNEL, "%pfwP", fwnode);
> > 
> > Is this better/cleaner than copying the string from fwnode_get_name?
> 
> Coying to where? And what would be the lifetime of that string?
> 
> With devm_kasprintf():
> - we don't care how long the string is
> - we don't care about corner cases of lifetime as it's the same as
>   device itself (i.o.w. the same as the IIO device container)

Curious if there isn't a devm_strdup(name) or similar?  Main point is
that %pfwP seems like magic when fwnode_get_name is not (but returns a
const string that we cannot modify).  If there is not, let's stick with
devm_kasprintf().

> > > +	name[strchrnul(name, '@') - name] = '\0';
> > 
> > This is the same as *strchrnul(name, '@') = '\0'; if I'm not mistaken.
> 
> Yes, But it's harder to read and understand. I believe the compiler has
> enough power to optimize this to the same assembly code.

I find the latter clearer as it doesn't require the reader to figure out
that name - name cancels itself out.  Alternatively we can write
strchrnul(name, '@')[0].

- Marijn



[Index of Archives]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Input]     [Linux Kernel]     [Linux SCSI]     [X.org]

  Powered by Linux