> From: Philippe De Muyter <phdm@xxxxxxxxx> > > We need the name 'st_lsm6dsx_ext_info' for the actual 'iio_chan_spec_ext_info'. > Rename the 'struct iio_info' to 'st_lsm6dsx_info' like in all other drivers. > > Signed-off-by: Philippe De Muyter <phdm@xxxxxxxxx> > --- > drivers/iio/imu/st_lsm6dsx/st_lsm6dsx_shub.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/iio/imu/st_lsm6dsx/st_lsm6dsx_shub.c b/drivers/iio/imu/st_lsm6dsx/st_lsm6dsx_shub.c > index f2b64b4956a3..43304b198040 100644 > --- a/drivers/iio/imu/st_lsm6dsx/st_lsm6dsx_shub.c > +++ b/drivers/iio/imu/st_lsm6dsx/st_lsm6dsx_shub.c > @@ -714,7 +714,7 @@ static const struct attribute_group st_lsm6dsx_ext_attribute_group = { > .attrs = st_lsm6dsx_ext_attributes, > }; > > -static const struct iio_info st_lsm6dsx_ext_info = { > +static const struct iio_info st_lsm6dsx_info = { maybe st_lsm6dsx_shub_info is a better name, what do you think? Moreover you can even rename: s/st_lsm6dsx_ext_attributes/st_lsm6dsx_shub_attributes/ s/st_lsm6dsx_ext_attribute_group/st_lsm6dsx_shub_attribute_group/ Regards, Lorenzo > .attrs = &st_lsm6dsx_ext_attribute_group, > .read_raw = st_lsm6dsx_shub_read_raw, > .write_raw = st_lsm6dsx_shub_write_raw, > @@ -737,7 +737,7 @@ st_lsm6dsx_shub_alloc_iiodev(struct st_lsm6dsx_hw *hw, > return NULL; > > iio_dev->modes = INDIO_DIRECT_MODE; > - iio_dev->info = &st_lsm6dsx_ext_info; > + iio_dev->info = &st_lsm6dsx_info; > > sensor = iio_priv(iio_dev); > sensor->id = id; > -- > 2.31.1 >
Attachment:
signature.asc
Description: PGP signature