> > > +static const int bmp580_oversampling_avail[] = { 1, 2, 4, 8, 16, 32, 64, > > > 128 }; > > > +static const int bmp580_iir_filter_coeffs_avail[] = { 1, 2, 4, 8, 16, 32, > > > 64, 128 }; > > > > Up to you, but you could take advantage of the fact this array matches the > > bmp380 one. > > It is arguable that the code is clearer with it not being reused though so > > your choice. > > Hum yes, I could reuse the array for the BMP380, maybe a should use a more > generic name for that array to avoid confusion? Something like > bmp280_iir_filter_coeffs_avail, refering to the driver name instead of the > concrete sensor? Don't worry about the naming. Anything clever just tends to cause problems as more parts are added. Just stick to the name of the first part that used it. We've made the mistake of trying for generic names in the past and it bites back! Jonathan