On Sun, Jul 17, 2022 at 10:08:37AM -0700, Joe Perches wrote: > On Sun, 2022-07-17 at 11:34 -0400, Joe Simmons-Talbott wrote: > > Prefer 'sizeof(var)' over 'sizeof var' as reported by checkpatch.pl. > > unrelated trivia: > > > diff --git a/drivers/iio/industrialio-trigger.c b/drivers/iio/industrialio-trigger.c > [] > > @@ -368,7 +368,7 @@ struct iio_poll_func > > va_list vargs; > > struct iio_poll_func *pf; > > > > - pf = kmalloc(sizeof *pf, GFP_KERNEL); > > + pf = kmalloc(sizeof(*pf), GFP_KERNEL); > > if (pf == NULL) > > return NULL; > > va_start(vargs, fmt); > > @@ -560,7 +560,7 @@ struct iio_trigger *viio_trigger_alloc(struct device *parent, > > struct iio_trigger *trig; > > int i; > > > > - trig = kzalloc(sizeof *trig, GFP_KERNEL); > > + trig = kzalloc(sizeof(*trig), GFP_KERNEL); > > if (!trig) > > return NULL; > > It'd be nice to be consistent with the allocation return test. > > Please pick one of: > > if (ptr == NULL) > or > if (!ptr) // my preference > I'm happy to submit a patch for that. Do you want me to include a Suggested-by: tag? Thanks, Joe