On Wed, 8 Jun 2022 23:11:51 +0300 Cosmin Tanislav <demonsingur@xxxxxxxxx> wrote: > On 6/8/22 18:59, Andy Shevchenko wrote: > > On Wed, Jun 8, 2022 at 12:19 PM Cosmin Tanislav <demonsingur@xxxxxxxxx> wrote: > >> > >> AD4130-8 is an ultra-low power, high precision, measurement solution for > >> low bandwidth battery operated applications. > >> > >> The fully integrated AFE (Analog Front-End) includes a multiplexer for up > >> to 16 single-ended or 8 differential inputs, PGA (Programmable Gain > >> Amplifier), 24-bit Sigma-Delta ADC, on-chip reference and oscillator, > >> selectable filter options, smart sequencer, sensor biasing and excitation > >> options, diagnostics, and a FIFO buffer. > > > > I believe we may gain a few LoCs by slightly bending the rule of 80. > > Also see below. > > > > I'll only go over the 80 columns limit if Jonathan agrees to it. Where it helps readability I fine with us going past 80. I'm not convinced by every case Andy highlights, but many do make things easier to read. > > >> + *size = ad4130_reg_size[reg]; > >> + if (!*size) > >> + return -EINVAL; > > > > Is this check necessary? > > > > Yes. I haven't described all registers in the table, and the registers > can be accessed by the user via the debugfs_reg_access() method. For that one, probably worth a comment as not immediately obvious. > ... > > >> + switch (ref_sel) { > >> + case AD4130_REF_REFIN1: > >> + ret = regulator_get_voltage(st->regulators[2].consumer); > >> + break; > >> + case AD4130_REF_REFIN2: > >> + ret = regulator_get_voltage(st->regulators[3].consumer); > >> + break; > >> + case AD4130_REF_AVDD_AVSS: > >> + ret = regulator_get_voltage(st->regulators[0].consumer); > >> + break; > >> + case AD4130_REF_REFOUT_AVSS: > >> + ret = st->int_ref_uv; > >> + break; > >> + default: > >> + ret = -EINVAL; > >> + break; > >> + } > > > >> + if (ret < 0) > >> + return dev_err_probe(dev, ret, "Cannot use reference %u\n", > >> + ref_sel); > > > > Can it be moved to the caller where it would cleaner to use, I think? > > As a good side effect the all above will be shortened to just return directly. > > > > I'm pretty sure I remember Jonathan suggested moving it inside the > function. It's possible, though I don't know what my reasoning would have been...