From: Cixi Geng <cixi.geng1@xxxxxxxxxx> this patchset add a sc27xx_adc_variant_data structure and add sc272*,sc273* and ump9620 PMIC support. v2 changes: fix dt_binding_check error adjust some code-style issue optimize the copy-paste functions the smatch warnings found by lkp and ohter comments by v1 patches. v3 changes: fix nvmem-cells Items value and add ump9620 dt sample add the correct signature for each patch fix the unused warning in 3/7, add explain for set the scales remove duplicate code,add goto label in sc27xx_adc_read pull out the refactor code into a single patch delete the suspend and resume pm for ump9620 v4 changes: Add fix tag in the 2/7 patch. Separate modification and refactoring 3/7(v3) to 2 pathes. remove the pmic_type struct instead of a boot set_volref to define the specific feathure. use switch statement in all scale_init functions. remove ump9620 pmic support in this patchset, submit separately in the next patches. Cixi Geng (7): dt-bindings:iio:adc: add sprd,ump9620-adc dt-binding iio: adc: sc27xx: fix read big scale voltage not right iio: adc: Fine tune the scale calibration values iio: adc: sc27xx: structure adjustment and optimization iio: adc: refactor some functions for support more PMiCs iio: adc: sc27xx: add support for PMIC sc2720 and sc2721 iio: adc: sc27xx: add support for PMIC sc2730 .../bindings/iio/adc/sprd,sc2720-adc.yaml | 59 ++- drivers/iio/adc/sc27xx_adc.c | 473 ++++++++++++++++-- 2 files changed, 491 insertions(+), 41 deletions(-) -- 2.25.1