Using scan_type has source of truth, use shift and realbits instead of constants when processing reading sensor registers to produce raw sysfs entries. The same shit and realbits are already used by the libiio user-space library to present channel information from device buffer. Fix only a handful of drivers, where channel scan_type was accessible in the function handling the raw data request. In mpl3115, use a 16 bit big endian buffer when reading temperature channel to improve readability. Gwendal Grignou (4): iio: Use scan_type shift and realbits when processing raw data iio: ti-ads1015: Remove shift variable ads1015_read_raw iio: xilinx-xadc-core: Use local variable in xadc_read_raw iio: mpl3115: Use scan_type.shift and realbit in mpl3115_read_raw drivers/iio/accel/bma220_spi.c | 3 ++- drivers/iio/accel/kxcjk-1013.c | 3 ++- drivers/iio/accel/mma7455_core.c | 3 ++- drivers/iio/accel/sca3000.c | 5 +++-- drivers/iio/accel/stk8312.c | 2 +- drivers/iio/accel/stk8ba50.c | 3 ++- drivers/iio/adc/ad7266.c | 3 ++- drivers/iio/adc/at91-sama5d2_adc.c | 3 ++- drivers/iio/adc/ti-adc12138.c | 3 ++- drivers/iio/adc/ti-ads1015.c | 8 +++----- drivers/iio/adc/xilinx-xadc-core.c | 2 +- drivers/iio/magnetometer/mag3110.c | 6 ++++-- drivers/iio/pressure/mpl3115.c | 16 +++++++++++----- 13 files changed, 37 insertions(+), 23 deletions(-) -- 2.33.1.1089.g2158813163f-goog