Re: [PATCH] iio: accel: sca3000: Use sign_extend32() instead of opencoding sign extension.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sun, 18 Jul 2021 16:16:12 +0100
Jonathan Cameron <jic23@xxxxxxxxxx> wrote:

> On Thu,  3 Jun 2021 17:47:29 +0100
> Jonathan Cameron <jic23@xxxxxxxxxx> wrote:
> 
> > From: Jonathan Cameron <Jonathan.Cameron@xxxxxxxxxx>
> > 
> > Whilst nice to get rid of this non obvious code, this also clears a
> > static checker warning:
> > 
> > drivers/iio/accel/sca3000.c:734 sca3000_read_raw()
> > warn: no-op. '((*val) << 19) >> 19'
> > 
> > Reported-by: Dan Carpenter <dan.carpenter@xxxxxxxxxx>
> > Signed-off-by: Jonathan Cameron <Jonathan.Cameron@xxxxxxxxxx>  
> 
> If someone could give this a quick sanity check that would be great.
> 

This one is still in the queue because I really don't like applying
my own patches without anyone having sanity checked them...

So if anyone has time to for a quick look that would be great.

> Thanks,
> 
> Jonathan
> 
> > ---
> >  drivers/iio/accel/sca3000.c | 3 +--
> >  1 file changed, 1 insertion(+), 2 deletions(-)
> > 
> > diff --git a/drivers/iio/accel/sca3000.c b/drivers/iio/accel/sca3000.c
> > index cb753a43533c..0692ccb80293 100644
> > --- a/drivers/iio/accel/sca3000.c
> > +++ b/drivers/iio/accel/sca3000.c
> > @@ -731,8 +731,7 @@ static int sca3000_read_raw(struct iio_dev *indio_dev,
> >  				return ret;
> >  			}
> >  			*val = (be16_to_cpup((__be16 *)st->rx) >> 3) & 0x1FFF;
> > -			*val = ((*val) << (sizeof(*val) * 8 - 13)) >>
> > -				(sizeof(*val) * 8 - 13);
> > +			*val = sign_extend32(*val, 13);
> >  		} else {
> >  			/* get the temperature when available */
> >  			ret = sca3000_read_data_short(st,  
> 




[Index of Archives]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Input]     [Linux Kernel]     [Linux SCSI]     [X.org]

  Powered by Linux