On Sun, 2021-08-08 at 18:46 -0400, Liam Beguin wrote: > On Sun Aug 8, 2021 at 12:51 PM EDT, Joe Perches wrote: > > On Sat, 2021-08-07 at 21:56 -0400, Liam Beguin wrote: > > > Replace raw configuration register values by using FIELD_PREP and > > > defines to improve readability. > > [] > > > diff --git a/drivers/iio/adc/ad7949.c b/drivers/iio/adc/ad7949.c > > [] > > +#define AD7949_CFG_BIT_INCC GENMASK(12, 10) > > > > Hi Joe, > > > I think the naming is a bit confusing as it appears as if > > these bitfield ranges are single bits. > > That makes sense. > Would AD7949_CFG_BITS_* be good enough? Sure, or add MASK or something else like AD7949_CFG_MASK_INCC. It's pretty common to define _MASK and _SHIFT for these types of uses. For instance: include/drm/drm_dp_helper.h-# define DP_DSC_MAJOR_MASK (0xf << 0) include/drm/drm_dp_helper.h-# define DP_DSC_MINOR_MASK (0xf << 4) include/drm/drm_dp_helper.h:# define DP_DSC_MAJOR_SHIFT 0 include/drm/drm_dp_helper.h:# define DP_DSC_MINOR_SHIFT 4