Re: [PATCH] iio: adf4350: Convert to use GPIO descriptor

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Dec 2, 2019 at 9:50 AM Ardelean, Alexandru
<alexandru.Ardelean@xxxxxxxxxx> wrote:

> > +     st->lock_detect_gpiod = devm_gpiod_get_optional(&spi->dev, NULL,
>
> Would it make sense to name the GPIO here?
> Maybe name it "lock-detect"?
>
> I do realize that this goes into the realm of changing some default
> behavior.
> And I am not sure how acceptable this is [generally].

You can't name it in the devm_gpiod_get_optional() call as this
indicates the name the GPIO lines have in the device tree.

What you can do is add a call to
gpiod_set_consumer_name(gpiod, "name");
to explicitly name the line.

This will only affect the name assigned to the line
in debugfs and in the userspace tools like "lsgpio".

Yours,
Linus Walleij



[Index of Archives]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Input]     [Linux Kernel]     [Linux SCSI]     [X.org]

  Powered by Linux