On Fri, 14 Jun 2019 13:32:21 -0300 Melissa Wen <melissa.srw@xxxxxxxxx> wrote: > Use the bitfield macro FIELD_GET, and GENMASK to do the shift and mask in > one go. This makes the code more readable than explicit masking followed > by a shift. > > Signed-off-by: Melissa Wen <melissa.srw@xxxxxxxxx> Applied to the togreg branch of iio.git and pushed out as testing for the autobuilders to paly with it. Thanks, Jonathan > --- > drivers/staging/iio/cdc/ad7150.c | 6 +++++- > 1 file changed, 5 insertions(+), 1 deletion(-) > > diff --git a/drivers/staging/iio/cdc/ad7150.c b/drivers/staging/iio/cdc/ad7150.c > index 8234da4b8c65..091aa33589d7 100644 > --- a/drivers/staging/iio/cdc/ad7150.c > +++ b/drivers/staging/iio/cdc/ad7150.c > @@ -5,6 +5,7 @@ > * Copyright 2010-2011 Analog Devices Inc. > */ > > +#include <linux/bitfield.h> > #include <linux/interrupt.h> > #include <linux/device.h> > #include <linux/kernel.h> > @@ -45,6 +46,9 @@ > #define AD7150_SN0 22 > #define AD7150_ID 23 > > +/* AD7150 masks */ > +#define AD7150_THRESHTYPE_MSK GENMASK(6, 5) > + > /** > * struct ad7150_chip_info - instance specific chip data > * @client: i2c client for this device > @@ -137,7 +141,7 @@ static int ad7150_read_event_config(struct iio_dev *indio_dev, > if (ret < 0) > return ret; > > - threshtype = (ret >> 5) & 0x03; > + threshtype = FIELD_GET(AD7150_THRESHTYPE_MSK, ret); > adaptive = !!(ret & 0x80); > > switch (type) {