On 03/01/2017 06:27 AM, sayli karnik wrote: > The patch groups similar macros into enum data types. > > Signed-off-by: sayli karnik <karniksayli1995@xxxxxxxxx> > --- > drivers/staging/iio/adc/ad7280a.h | 20 ++++++++++++-------- > 1 file changed, 12 insertions(+), 8 deletions(-) > > diff --git a/drivers/staging/iio/adc/ad7280a.h b/drivers/staging/iio/adc/ad7280a.h > index ccfb90d..08e97d4 100644 > --- a/drivers/staging/iio/adc/ad7280a.h > +++ b/drivers/staging/iio/adc/ad7280a.h > @@ -13,15 +13,19 @@ > * TODO: struct ad7280_platform_data needs to go into include/linux/iio > */ > > -#define AD7280A_ACQ_TIME_400ns 0 > -#define AD7280A_ACQ_TIME_800ns 1 > -#define AD7280A_ACQ_TIME_1200ns 2 > -#define AD7280A_ACQ_TIME_1600ns 3 > +enum { Sorry, I should have been more specific on the previous mail. This should be named enum, like 'enum ad7280a_conv_avg' and then use the enum type instead of unsigned int for the field in the platform_data struct. This makes sure that the there is a clear dependency between the values and the field. > + AD7280A_CONV_AVG_DIS = 0, > + AD7280A_CONV_AVG_2, > + AD7280A_CONV_AVG_4, > + AD7280A_CONV_AVG_8, > +}; > > -#define AD7280A_CONV_AVG_DIS 0 > -#define AD7280A_CONV_AVG_2 1 > -#define AD7280A_CONV_AVG_4 2 > -#define AD7280A_CONV_AVG_8 3 > +enum { Same here. > + AD7280A_ACQ_TIME_400ns = 0, > + AD7280A_ACQ_TIME_800ns, > + AD7280A_ACQ_TIME_1200ns, > + AD7280A_ACQ_TIME_1600ns, > +}; > > #define AD7280A_ALERT_REMOVE_VIN5 BIT(2) > #define AD7280A_ALERT_REMOVE_VIN4_VIN5 BIT(3) > -- To unsubscribe from this list: send the line "unsubscribe linux-iio" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html