On 22/08/16 23:19, Matt Ranostay wrote: > Now there are channel modifiers with their own scaling those should be > used when possible over the generic channel type scaling. > > Examples are of IIO_TEMP channel having a generic scaling value, and > another having IIO_MOD_TEMP_AMBIENT modifier with another scaling value. > > Previously the first scaling value for a channel type would be applied > to all channels of like type in iio_generic_buffer > > Signed-off-by: Matt Ranostay <mranostay@xxxxxxxxx> Applied. Thanks. I remember a long time ago wondering if we should ever allow a hierarchy like this and never making my mind up. If we have these out in the wild, not much choice really! Jonathan > --- > > Changes from v1: > > * make commit message more verbose > > tools/iio/iio_utils.c | 11 +++++++---- > 1 file changed, 7 insertions(+), 4 deletions(-) > > diff --git a/tools/iio/iio_utils.c b/tools/iio/iio_utils.c > index 5eb6793f3972..7a6d61c6c012 100644 > --- a/tools/iio/iio_utils.c > +++ b/tools/iio/iio_utils.c > @@ -121,10 +121,6 @@ int iioutils_get_type(unsigned *is_signed, unsigned *bytes, unsigned *bits_used, > > ret = -ENOENT; > while (ent = readdir(dp), ent) > - /* > - * Do we allow devices to override a generic name with > - * a specific one? > - */ > if ((strcmp(builtname, ent->d_name) == 0) || > (strcmp(builtname_generic, ent->d_name) == 0)) { > ret = asprintf(&filename, > @@ -178,6 +174,13 @@ int iioutils_get_type(unsigned *is_signed, unsigned *bytes, unsigned *bits_used, > sysfsfp = 0; > free(filename); > filename = 0; > + > + /* > + * Avoid having a more generic entry overwriting > + * the settings. > + */ > + if (strcmp(builtname, ent->d_name) == 0) > + break; > } > > error_close_sysfsfp: > -- To unsubscribe from this list: send the line "unsubscribe linux-iio" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html