On Wed, 29 Apr 2015 18:08:41 +0300 Daniel Baluta <daniel.baluta@xxxxxxxxx> wrote: > On Wed, Apr 29, 2015 at 12:01 PM, Antonio Ospite <ao2@xxxxxx> wrote: > > The purpose of the variable is to remember when an interrupt cannot be > > requested and hence the driver must work in polling mode, so tell that > > instead of mentioning the specific case when this is needed. > > > > This makes the variable name to be still meaningful when some other > > devices requiring this show up. > > > > Signed-off-by: Antonio Ospite <ao2@xxxxxx> > > Cc: Jonathan Cameron <jic23@xxxxxxxxxx> > > Cc: Bastien Nocera <hadess@xxxxxxxxxx> > > Cc: linux-iio@xxxxxxxxxxxxxxx > > --- > > drivers/iio/accel/kxcjk-1013.c | 10 +++++----- > > 1 file changed, 5 insertions(+), 5 deletions(-) > > > > diff --git a/drivers/iio/accel/kxcjk-1013.c b/drivers/iio/accel/kxcjk-1013.c > > index 5b7a860..eccec0e 100644 > > --- a/drivers/iio/accel/kxcjk-1013.c > > +++ b/drivers/iio/accel/kxcjk-1013.c > > @@ -108,7 +108,7 @@ struct kxcjk1013_data { > > bool motion_trigger_on; > > int64_t timestamp; > > enum kx_chipset chipset; > > - bool is_smo8500_device; > > + bool polling_mode; > > I would prefer to call this field use_poll, as introduced in: > > http://marc.info/?l=linux-iio&m=142980650422289&w=2 > Looking at it again I realize that the current meaning of is_smo8500_device is more like "gpio interrupt not available" rather than an explicit indication to use polling mode, which right now is a userspace thing anyway. It was mainly to prevent error messages being printed in the logs when trying to getting a gpio descriptor, is that correct Bastien? > Also use_poll its it's a better suggestion on the type than polling_mode. > Agreed, polling_mode was not the best name. How about we drop this patch 2/3 altogether for now and I just resend 1 and 3? Renaming (or even removing) is_smo8500_device can be re-evaluated when use_poll gets added. Thanks, Antonio -- Antonio Ospite http://ao2.it A: Because it messes up the order in which people normally read text. See http://en.wikipedia.org/wiki/Posting_style Q: Why is top-posting such a bad thing? -- To unsubscribe from this list: send the line "unsubscribe linux-iio" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html