On Wed, Apr 29, 2015 at 12:01 PM, Antonio Ospite <ao2@xxxxxx> wrote: > The purpose of the variable is to remember when an interrupt cannot be > requested and hence the driver must work in polling mode, so tell that > instead of mentioning the specific case when this is needed. > > This makes the variable name to be still meaningful when some other > devices requiring this show up. > > Signed-off-by: Antonio Ospite <ao2@xxxxxx> > Cc: Jonathan Cameron <jic23@xxxxxxxxxx> > Cc: Bastien Nocera <hadess@xxxxxxxxxx> > Cc: linux-iio@xxxxxxxxxxxxxxx > --- > drivers/iio/accel/kxcjk-1013.c | 10 +++++----- > 1 file changed, 5 insertions(+), 5 deletions(-) > > diff --git a/drivers/iio/accel/kxcjk-1013.c b/drivers/iio/accel/kxcjk-1013.c > index 5b7a860..eccec0e 100644 > --- a/drivers/iio/accel/kxcjk-1013.c > +++ b/drivers/iio/accel/kxcjk-1013.c > @@ -108,7 +108,7 @@ struct kxcjk1013_data { > bool motion_trigger_on; > int64_t timestamp; > enum kx_chipset chipset; > - bool is_smo8500_device; > + bool polling_mode; I would prefer to call this field use_poll, as introduced in: http://marc.info/?l=linux-iio&m=142980650422289&w=2 Also use_poll its it's a better suggestion on the type than polling_mode. Other than that the patch looks good. thanks, Daniel. -- To unsubscribe from this list: send the line "unsubscribe linux-iio" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html