Re: [PATCH v6 03/11] ata: libata: Use QUIRK instead of HORKAGE

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Jul 26, 2024 at 12:19:46PM +0900, Damien Le Moal wrote:
> According to Wiktionary, the verb "hork" is computing slang defined as
> "To foul up; to be occupied with difficulty, tangle, or unpleasantness;
> to be broken" (https://en.wiktionary.org/wiki/hork#Verb). libata uses
> this with the term "horkage" to refer to broken device features. Given
> that this term is not widely used and its meaning unknown to many,
> rename it to the more commonly used term "quirk", similar to many other
> places in the kernel.
> 
> The renaming done is:
> 1) Rename all ATA_HORKAGE_XXX flags to ATA_QUIRK_XXX
> 2) Rename struct ata_device horkage field to quirks
> 3) Rename struct ata_blacklist_entry to struct ata_dev_quirks_entry. The
>    array of these structures defining quirks for known devices is
>    renamed __ata_dev_quirks.
> 4) The functions ata_dev_blacklisted() and ata_force_horkage() are
>    renamed to ata_dev_quirks() and ata_force_quirks() respectively.
> 5) All the force_horkage_xxx() macros are renamed to force_quirk_xxx()
> 
> And while at it, make sure that the type "unsigned int" is used
> consistantly for quirk flags variables and data structure fields.
> 
> Signed-off-by: Damien Le Moal <dlemoal@xxxxxxxxxx>
> ---

(It might have been easier to review if there was one patch that just renamed
the ATA_HORKAGE_ flags to ATA_QUIRK_, and then one patch that renamed
everything else, even if that means that the same line would be touched twice
in about half the changed lines.)

Legacy aside, I really like the fact that libata now aligns with the rest of
the kernel code base:
Reviewed-by: Niklas Cassel <cassel@xxxxxxxxxx>




[Index of Archives]     [Linux Filesystems]     [Linux SCSI]     [Linux RAID]     [Git]     [Kernel Newbies]     [Linux Newbie]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Samba]     [Device Mapper]

  Powered by Linux