[PATCH v6 0/4] Some cleanup, renaming and horkage improvements

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Patch 1 cleanups the function ata_dev_knobble() and patch 2 renames the
function ata_dma_blacklisted(). Patch 3 does a larger cleanup, changing
the use of the term horkage to the more common quirk term. All 3 patches
do not introduce any functional change.

Patch 4 adds printing on device scan of the quirk flags that will be
applied to the device,. This is to help with debugging any issue with
devices.

Finally, patches 5 to 11 do some additional renaming and comment
cleanups in various drivers to remove the use of the term blacklist,
replacing it with more descriptive comments and names. Of note is that
many of the "broken" device handling in these driver should probably be
moved to libata quirk handling so that any controller seeing one of the
broken device listed can get similar quirks. But it is unclear if the
quirks handled are controller specific or not.

Changes from v5:
 - Moved patch 3 as patch 1
 - Changed patch 2 to do the horkage renaming, including renaming of
   ata_dev_blacklisted(). That is now patch 3.
 - Changed patch 4 to be compatible with the changes introduced in
   patch 3.
 - Added patch 5 to 11

Changes from v4:
 - Removed the useless !! in patch 1
 - Added Igor's review tags to patch 1 and 2
 - Added patch 3
 - In patch 4, corrected comment about __ATA_HORKAGE_MAX, added missing
   newline for the horkage warning message and corrected the commit
   message.

Changes from v3:
 - Corrected the BUILD_BUG_ON() call in patch 3
 - Corrected alignment of horkage definition comments in patch 3

Changes from v2:
 - Simplified ata_dev_print_horkage() to always print the device
   revision (patch 3)
 - Simplified ata_dev_horkage() to having 2 different calls to
   ata_dev_print_horkage() and to always print the device revision
   (patch 3)
 - Added a BUILD_BUG_ON() check in patch 3 to ensure that the horkage
   flags all fit within an unsigned int.

Changes from v1:
 - Remove unused macro definition in patch 3
 - Use unsigned int for horkage flags (patch 3)

Damien Le Moal (11):
  ata: libata: Change ata_dev_knobble() to return a bool
  ata: libata: Rename ata_dma_blacklisted()
  ata: libata: Use QUIRK instead of HORKAGE
  ata: libata: Print quirks applied to devices
  ata: pata_serverworks: Do not use the term blacklist
  ata: ahci: Rephrase comment to not use the term blacklist
  ata: sata_sil: Rename sil_blacklist to sil_quirks
  ata: ata_piix: Remove useless comment in piix_init_sidpr()
  ata: pata_cs5520: Rephrase file header comment
  ata: pata_hpt366: Rename hpt_dma_blacklisted()
  ata: pata_hpt37x: Rename hpt_dma_blacklisted()

 drivers/ata/ahci.c             |   2 +-
 drivers/ata/ata_piix.c         |   1 -
 drivers/ata/libata-core.c      | 581 ++++++++++++++++++---------------
 drivers/ata/libata-sata.c      |   2 +-
 drivers/ata/libata-scsi.c      |   9 +-
 drivers/ata/libata-sff.c       |  10 +-
 drivers/ata/libata-transport.c |   6 +-
 drivers/ata/pata_cs5520.c      |   6 +-
 drivers/ata/pata_hpt366.c      |  10 +-
 drivers/ata/pata_hpt37x.c      |  10 +-
 drivers/ata/pata_it821x.c      |   4 +-
 drivers/ata/pata_serverworks.c |  16 +-
 drivers/ata/sata_sil.c         |  14 +-
 include/linux/libata.h         | 115 ++++---
 14 files changed, 446 insertions(+), 340 deletions(-)

-- 
2.45.2





[Index of Archives]     [Linux Filesystems]     [Linux SCSI]     [Linux RAID]     [Git]     [Kernel Newbies]     [Linux Newbie]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Samba]     [Device Mapper]

  Powered by Linux