RE: [PATCH v1 08/23] ata: sata_dwc_460ex: don't call ata_sff_qc_issue() on DMA commands

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



From: Andy Shevchenko
> Sent: 21 April 2016 19:15
> ata_sff_qc_issue() can't handle DMA commands and thus we have to avoid it for
> them. Do call ata_bmdma_qc_issue() instead for this case.
> 
> Suggested-by: Christian Lamparter <chunkeey@xxxxxxxxxxxxxx>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
> ---
>  drivers/ata/sata_dwc_460ex.c | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/ata/sata_dwc_460ex.c b/drivers/ata/sata_dwc_460ex.c
> index 038e5fb..845c35d 100644
> --- a/drivers/ata/sata_dwc_460ex.c
> +++ b/drivers/ata/sata_dwc_460ex.c
> @@ -1061,10 +1061,12 @@ static unsigned int sata_dwc_qc_issue(struct ata_queued_cmd *qc)
>  			__func__, tag, qc->ap->link.sactive, sactive);
> 
>  		ap->ops->sff_tf_load(ap, &qc->tf);
> -		sata_dwc_exec_command_by_tag(ap, &qc->tf, qc->tag,
> +		sata_dwc_exec_command_by_tag(ap, &qc->tf, tag,
>  					     SATA_DWC_CMD_ISSUED_PEND);
> +	} else if (ata_is_dma(qc->tf.protocol)) {
> +		return ata_bmdma_qc_issue(qc);
>  	} else {
> -		ata_sff_qc_issue(qc);
> +		return ata_sff_qc_issue(qc);
>  	}
>  	return 0;
>  }

I'd nuke those 'else if', they make it very hard to read.
I Think the code is:

		sata_dwc_exec_command_by_tag(...);
		return 0;
	}

	if (ata_is_dma(qc->tf.protocol))
		return ata_bmdma_qc_issue(qc);

	return ata_sff_qc_issue(qc);
}

	David

��.n��������+%������w��{.n�����{��'^�)��jg��������ݢj����G�������j:+v���w�m������w�������h�����٥




[Index of Archives]     [Linux Filesystems]     [Linux SCSI]     [Linux RAID]     [Git]     [Kernel Newbies]     [Linux Newbie]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Samba]     [Device Mapper]

  Powered by Linux