Hello, David. On Fri, Jan 10, 2014 at 02:07:21PM -0600, David Milburn wrote: > Tejun, to avoid some of the interrupt handling code duplication, would > it better to have a AHCI_HFLAG_FLUSH and then change > > this driver to set flush > > hpriv->hpriv.flush = (void *) xgene_ahci_iob_flush; > > and then standard code flush when necessary > > ahci_handle_port_interrupt > > /* board-specific flush before servicing completed cmds */ > if (hpriv-> flags & AHCI_HFLAG_FLUSH) > hpriv->flush(hpriv); And this would be the only spot that this would be necessary? If so, why not just wrap the interrupt handler? Thanks. -- tejun -- To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html