From: Mac Lin <mkl0301@xxxxxxxxx> Due to build system limitations, intermediate and final objects can't have the same names. And as we're going to start building SoC-specific objects, rename ahci_platform to ahci_platforms, into which link ahci_platform and SoC-specific objects. Signed-off-by: Mac Lin <mkl0301@xxxxxxxxx> Acked-by: Anton Vorontsov <cbouatmailru@xxxxxxxxx> --- drivers/ata/Makefile | 4 +++- 1 files changed, 3 insertions(+), 1 deletions(-) diff --git a/drivers/ata/Makefile b/drivers/ata/Makefile index 2b67c90..d17bfe7 100644 --- a/drivers/ata/Makefile +++ b/drivers/ata/Makefile @@ -3,7 +3,9 @@ obj-$(CONFIG_ATA) += libata.o # non-SFF interface obj-$(CONFIG_SATA_AHCI) += ahci.o libahci.o -obj-$(CONFIG_SATA_AHCI_PLATFORM) += ahci_platform.o libahci.o +obj-$(CONFIG_SATA_AHCI_PLATFORM) += ahci_platforms.o libahci.o +ahci_platforms-y += ahci_platform.o + obj-$(CONFIG_SATA_FSL) += sata_fsl.o obj-$(CONFIG_SATA_INIC162X) += sata_inic162x.o obj-$(CONFIG_SATA_SIL24) += sata_sil24.o -- 1.7.3 -- To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html