Kay Sievers wrote:
On Mon, Jan 5, 2009 at 19:54, Jens Axboe <jens.axboe@xxxxxxxxxx> wrote:
On Mon, Jan 05 2009, Bartlomiej Zolnierkiewicz wrote:
+static struct queue_sysfs_entry queue_nonrot_entry = {
+ .attr = {.name = "nonrot", .mode = S_IRUGO | S_IWUSR },
+ .show = queue_nonrot_show,
+ .store = queue_nonrot_store,
+};
+
Lets please use a better name for export reasons, non-rotational is a
lot better. Nobody will know what nonrot means :-)
What's that negation good for? Can't we just have "rotational", like
we have "removable" and not "non-removable"? :)
How about cheapseek? fastrandom? flash? ssd? However the internal flag
is called QUEUE_FLAG_NONROT so it kind of makes sense just to leave it
as nonrot...
--
To unsubscribe from this list: send the line "unsubscribe linux-ide" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html