On Mon, Jan 05 2009, Bartlomiej Zolnierkiewicz wrote: > From: Bartlomiej Zolnierkiewicz <bzolnier@xxxxxxxxx> > Subject: [PATCH] block: export SSD/non-rotational queue flag through sysfs > > For some devices (i.e. CFA ATA) we can't reliably detect whether > the device is of rotational or non-rotational type so we need to > leave the final decision about this setting to the user-space. I agree with that, was actually planning on doing that myself. > @@ -146,8 +167,8 @@ static ssize_t queue_nomerges_store(stru > queue_flag_set(QUEUE_FLAG_NOMERGES, q); > else > queue_flag_clear(QUEUE_FLAG_NOMERGES, q); > - > spin_unlock_irq(q->queue_lock); > + > return ret; > } > Hmm? > @@ -210,6 +231,12 @@ static struct queue_sysfs_entry queue_hw > .show = queue_hw_sector_size_show, > }; > > +static struct queue_sysfs_entry queue_nonrot_entry = { > + .attr = {.name = "nonrot", .mode = S_IRUGO | S_IWUSR }, > + .show = queue_nonrot_show, > + .store = queue_nonrot_store, > +}; > + Lets please use a better name for export reasons, non-rotational is a lot better. Nobody will know what nonrot means :-) -- Jens Axboe -- To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html