Jeff Garzik wrote:
Mark Lord wrote:
..
- irq_stat = readl(hpriv->main_cause_reg_addr);
- irq_mask = readl(hpriv->main_mask_reg_addr);
..
+ main_cause = readl(hpriv->main_cause_reg_addr);
+ main_mask = readl(hpriv->main_mask_reg_addr);
..
...but I am sad to see this. irq_stat and irq_mask naming make the
driver more accessible to outsiders, because the purpose of the
registers is immediately apparent even without having the docs at hand
-- which is the case for everybody in the world except me and you :)
I applied the patch anyway because you are defacto maintainer of sata_mv.
However, I _request_ a reconsideration of some of these renames when
viewed in that light. It's your prerogative as maintainer to ignore or
honor that request as you see fit... We all have to balance making our
own job easier with making the driver accessible to outsiders,
particularly those without NDA'd docs.
..
Thanks, Jeff.
I agree, too, in principle if not in deed at the moment.
But there are just *so many* irq cause / mask registers in these chips,
(one for PCI, one for the host function, and one per-port for EDMA,
plus the SATA SError + mask, ..), that even I was getting confused
while working on the code.
So, for now, they've been renamed back to something closer to
what is used in the (NDA only) documentation.
I did consider main_irq_{cause,mask} as an even better set of names there,
but in the end went for the shortened versions to avoid hitting the
pedantic 80-character line "limits" too often.
Perhaps after we finish the major hacking around the interrupt/EH code
(yes, more to come..) we can try and fix up those names again.
I'll put it on the next TODO list update.
Cheers
--
To unsubscribe from this list: send the line "unsubscribe linux-ide" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html