saeed.bishara@xxxxxxxxx wrote:
--- /dev/null +++ b/include/linux/sata_mv.h @@ -0,0 +1,21 @@ +/* + * Marvell integrated SATA platfrom device data definition file. + * + * Saeed Bishara <saeed@xxxxxxxxxxx> + * + * This file is licensed under the terms of the GNU General Public + * License version 2. This program is licensed "as is" without any + * warranty of any kind, whether express or implied. + */ + +#ifndef __LINUX_SATA_MV_H__ +#define __LINUX_SATA_MV_H__ + +/* + * Sata private data + */ +struct mv_sata_platform_data { + int n_ports; /* number of sata ports */ +}; + +#endif
Overall, the patch is OK, but I fear adding way too many of these tiny includes, for each platform.
Unless Paul M objects (pata_platform maintainer), I will rename linux/pata_platform.h to linux/ata_platform.h, and we can put your mv_sata_platform_data structure in there.
Jeff - To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html