On Sunday 13 January 2008, Borislav Petkov wrote: > We merge idefloppy_{input,output}_buffers() into idefloppy_io_buffers() by > introducing a 4th arg. called direction. According to its value > we atapi_input_bytes() or atapi_output_bytes(). Also, this simplifies the > interrupt handler logic a bit. Finally, rename idefloppy_io_buffers() to > ide_floppy_io_buffers(). > > Signed-off-by: Borislav Petkov <bbpetkov@xxxxxxxx> This change depends on "ide-floppy: use an xfer_func_t and io_buf_t typedefs in order to unify rw" which was not in the "v2.5" series. I took the patch #16/21 from the previous series and applied it manually fixing rejects, please verify that I didn't brake something in the process. [...] > @@ -380,8 +352,13 @@ static void idefloppy_output_buffers (ide_drive_t *drive, idefloppy_pc_t *pc, un > idefloppy_do_end_request(drive, 1, done >> 9); > > if (bcount) { > - printk(KERN_ERR "%s: leftover data in idefloppy_output_buffers, bcount == %d\n", drive->name, bcount); > - idefloppy_write_zeros(drive, bcount); > + printk(KERN_ERR "%s: leftover data in idefloppy_output_buffers," > + " bcount == %d\n", drive->name, bcount); I fixed the above to use __func__ while at it. [ __FUNCTION__ is gcc-specific, __func__ is in C99 and is shorter ] - To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html