On Tuesday 11 December 2007, Sergei Shtylyov wrote: > Bartlomiej Zolnierkiewicz wrote: > > > * Rename init_hwif_data() to ide_init_port_data() and export it. > > > * For all users of ide_register_hw() with 'initializing' argument set > > hwif->present and hwif->hold are always zero so convert these host > > drivers to use ide_find_port()+ide_init_port_data()+ide_init_port_hw() > > instead (also no need for init_hwif_default() call since the setup > > done by it gets over-ridden by ide_init_port_data() call). > > But init_hwif_default() gets called *after* ide_init_port_data() call, at > least in ide_register_hw()... This is a mistake in the patch description: s/ide_init_port_data/ide_init_port_hw/ [ I fixed it locally ] > > * Drop 'initializing' argument from ide_register_hw(). > > > Signed-off-by: Bartlomiej Zolnierkiewicz <bzolnier@xxxxxxxxx> > > > Index: b/drivers/ide/ide.c > > =================================================================== > > --- a/drivers/ide/ide.c > > +++ b/drivers/ide/ide.c > > @@ -116,7 +116,7 @@ EXPORT_SYMBOL(ide_hwifs); > > /* > > * Do not even *think* about calling this! > > */ > > Isn't this comment being obsoleted by the patch? It is still valid because ide_init_port_data() destroys "hdx=" and "idex=" kernel parameters... Thanks, Bart - To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html