On Tue, Dec 12, 2006 at 11:08:24AM +0900, Akira Iguchi wrote: > > I use some static functions in libata-core.c because it makes You will want to split this patch into several pars, and submit the changes to libata-core.c separately. > --- linux-2.6.19/drivers/ata/libata-core.c Wed Dec 6 12:00:47 2006 > *************** > *** 600,606 **** > * Device type - %ATA_DEV_ATA, %ATA_DEV_ATAPI or %ATA_DEV_NONE. > */ > > ! static unsigned int > ata_dev_try_classify(struct ata_port *ap, unsigned int device, u8 *r_err) > { > struct ata_taskfile tf; > --- 600,606 ---- > * Device type - %ATA_DEV_ATA, %ATA_DEV_ATAPI or %ATA_DEV_NONE. > */ > > ! unsigned int > ata_dev_try_classify(struct ata_port *ap, unsigned int device, u8 *r_err) Please generate unified diffs (diff -pu) or use quilt, this makes the patches easier to read. (and smaller) --linas - To unsubscribe from this list: send the line "unsubscribe linux-ide" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html