Re: [PATCH 1/20] libata: kill ata_host_stop()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Jeff Garzik wrote:
Tejun Heo wrote:
As all the current LLDs are PCI, ata_pci_host_stop() should be used,
which BTW is effectively identical to ata_host_stop().  Convert all
LLDs to use ata_pci_host_stop() and kill ata_host_stop().

NAK, they are not equivalent replacements:

* ata_host_stop checks mmio_base before calling iounmap. Most of the drivers you change do not use ioremap (thus it's really a no-op call for them)

* ata_pci_host_stop not only unmaps unconditionally, it calls pci_iounmap(). Only drivers which have previously used pci_iomap() should use this helper.

This patch may make sense later in the patch series, when ata_pci_host_stop presumably works for all iomap-converted drivers, but not really as the first patch?

It's the first patch because I wanted to free the function name ata_host_stop(), which will be used for another purpose in new init model. As the new use isn't a port op, there shouldn't be too much confusion.

Hmmm.. I'll push this backward and use different name for it.

Thanks.

--
tejun
-
To unsubscribe from this list: send the line "unsubscribe linux-ide" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [Linux Filesystems]     [Linux SCSI]     [Linux RAID]     [Git]     [Kernel Newbies]     [Linux Newbie]     [Security]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Samba]     [Device Mapper]

  Powered by Linux