On Mon, Mar 08, 2021 at 12:36:07PM +0800, Hsin-Yi Wang wrote: > + adap->bus_regulator = devm_regulator_get(&adap->dev, "bus"); > + if (IS_ERR(adap->bus_regulator)) { > + res = PTR_ERR(adap->bus_regulator); > + goto out_reg; > + } Idiomatically supplies should be named as they are by the chip datasheet rather than just a generic name like this, and I'm guessing that systems that have supplies like this will often already have something requesting the supply (eg, it's quite common for consumer drivers to do this) under that name. I can see this being a useful thing to factor out into the core but it seems like it'd be better to have it enabled by having the controllers (or devices) pass a supply name (or possibly requested regulator) to the core rather than by just hard coding a name in the core so bindings look as expected. I do also wonder if it's better to put the feature on the clients rather than the controller, I don't think it makes much difference though.
Attachment:
signature.asc
Description: PGP signature