2017-11-16 21:26 GMT+01:00 Heiner Kallweit <hkallweit1@xxxxxxxxx>: > Change return type of at24_translate_offset to *at24_client to make > member regmap accessible for subsequent patches of this series. > > Signed-off-by: Heiner Kallweit <hkallweit1@xxxxxxxxx> > --- > v2: > - rebased > --- > drivers/misc/eeprom/at24.c | 24 ++++++++++++------------ > 1 file changed, 12 insertions(+), 12 deletions(-) > > diff --git a/drivers/misc/eeprom/at24.c b/drivers/misc/eeprom/at24.c > index 911cce8ec..1411fa029 100644 > --- a/drivers/misc/eeprom/at24.c > +++ b/drivers/misc/eeprom/at24.c > @@ -267,8 +267,8 @@ MODULE_DEVICE_TABLE(acpi, at24_acpi_ids); > * one "eeprom" file not four, but larger reads would fail when > * they crossed certain pages. > */ > -static struct i2c_client *at24_translate_offset(struct at24_data *at24, > - unsigned int *offset) > +static struct at24_client *at24_translate_offset(struct at24_data *at24, > + unsigned int *offset) > { > unsigned i; > > @@ -280,7 +280,7 @@ static struct i2c_client *at24_translate_offset(struct at24_data *at24, > *offset &= 0xff; > } > > - return at24->client[i].client; > + return &at24->client[i]; > } > > static ssize_t at24_eeprom_read_smbus(struct at24_data *at24, char *buf, > @@ -290,7 +290,7 @@ static ssize_t at24_eeprom_read_smbus(struct at24_data *at24, char *buf, > struct i2c_client *client; > int status; > > - client = at24_translate_offset(at24, &offset); > + client = at24_translate_offset(at24, &offset)->client; Please do something like: struct at24_client *at24; struct i2c_client *client; at24 = at24_translate_offset(at24, &offset); client = at24->client; I find it more readable like that and we don't hide the type of the return value of at24_translate_offset(). Thanks, Bartosz