Re: [PATCH] i2c_intel_mid: Fix slash in sysfs name

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 15/12/10 09:08, Jean Delvare wrote:
> Hi Alan,
> 
> On Tue, 14 Dec 2010 15:29:08 +0000, Alan Cox wrote:
>> From: Alan Cox <alan@xxxxxxxxxxxxxxx>
>>
>> This gets caught by the new sanity check code.
> 
> New sanity check of what? Where's the code?
> 
>> Instead of the slash use a
>> different symbol. This was originally found by Major Lee who proposed a
>> rather more complex patch which changed the name according to the chip
>> type.
>>
>> On the basis that we are in a late -rc and making Linus grumpy isn't always
>> a good idea (however fun) this is a simple alternative.
>>
>> Signed-off-by: Alan Cox <alan@xxxxxxxxxxxxxxx>
>> ---
>>
>>  drivers/i2c/busses/i2c-intel-mid.c |    2 +-
>>  1 files changed, 1 insertions(+), 1 deletions(-)
>>
>>
>> diff --git a/drivers/i2c/busses/i2c-intel-mid.c b/drivers/i2c/busses/i2c-intel-mid.c
>> index 657f314..da4bbdd 100644
>> --- a/drivers/i2c/busses/i2c-intel-mid.c
>> +++ b/drivers/i2c/busses/i2c-intel-mid.c
>> @@ -1035,7 +1035,7 @@ static int __devinit intel_mid_i2c_probe(struct pci_dev *dev,
>>  
>>  	/* Initialize struct members */
>>  	snprintf(mrst->adap.name, sizeof(mrst->adap.name),
>> -		"MRST/Medfield I2C at %lx", start);
>> +		"Intel MID I2C at %lx", start);
>>  	mrst->adap.owner = THIS_MODULE;
>>  	mrst->adap.algo = &intel_mid_i2c_algorithm;
>>  	mrst->adap.dev.parent = &dev->dev;
> 
> Having a slash in an I2C adapter name shouldn't be a problem. The real
> problem is below:
> 
> 	err = request_irq(dev->irq, intel_mid_i2c_isr, IRQF_SHARED,
> 					mrst->adap.name, mrst);
> 
> Using the adapter name to request the IRQ is silly. The very same issue
> was fixed in i2c-pca-platform recently:
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=323584436db0cb05286425d4dfd9516fce88487f

I agree, something like dev_name(dev) is much better for readability
of /proc/interruopts


> You want to use a short name for the interrupt. Either the driver name,
> or if you really want something device-specific, the bus device name.
> 

--
To unsubscribe from this list: send the line "unsubscribe linux-i2c" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux GPIO]     [Linux SPI]     [Linux Hardward Monitoring]     [LM Sensors]     [Linux USB Devel]     [Linux Media]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux