On Fri Sep 29, 2023 at 12:50 PM CEST, Viresh Kumar wrote: > $subject: s/OwnedInfo/InfoOwned/ Whoops. Flipped that around at some point. Forgot to fix here... Will do once we agreed on a naming scheme :) > > On 28-09-23, 14:52, Erik Schilling wrote: > > On Wed Sep 27, 2023 at 6:29 PM CEST, Erik Schilling wrote: > > > diff --git a/bindings/rust/libgpiod/src/line_info.rs b/bindings/rust/libgpiod/src/line_info.rs > > > index 32c4bb2..fe01a14 100644 > > > --- a/bindings/rust/libgpiod/src/line_info.rs > > > +++ b/bindings/rust/libgpiod/src/line_info.rs > > > @@ -58,6 +58,22 @@ impl Info { > > > self as *const _ as *mut _ > > > } > > > > > > + /// Clones the [gpiod::gpiod_line_info] instance to an [InfoOwned] > > > + pub fn try_clone(&self) -> Result<InfoOwned> { > > > > Hm... I realized that we have `event_clone()` for cloning an `Event` > > and `settings_clone()` for cloning `line::Settings`. Should better > > stay consistent here... > > > > However, I think the name `try_clone()` sounds more suitable to me. Any > > opinions? I could send a patch to rename the existing cloning methods > > to `try_clone()`. > > IIRC, I did try to use clone() and try_clone() earlier for something and there > were prototype issues, as they weren't matching with the standard library and so > had to innovate `event_clone()` and `settings_clone()`. `try_clone()` is anyday > better. ACK. I am not aware of any trait like `TryClone`, but yeah: `Clone` and `ToOwned` do not work for the reason outlined in the commit message. I will then add a commit to rename the other `*_clone` functions to `try_clone` in v2. - Erik