On Wed, Nov 11, 2020 at 05:57:17PM +0200, Mika Westerberg wrote: > On Mon, Nov 09, 2020 at 10:53:31PM +0200, Andy Shevchenko wrote: > > We may use BIT() macro to increase readability in > > acpi_gpio_adr_space_handler(). > > > > Signed-off-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx> > > --- > > drivers/gpio/gpiolib-acpi.c | 3 +-- > > 1 file changed, 1 insertion(+), 2 deletions(-) > > > > diff --git a/drivers/gpio/gpiolib-acpi.c b/drivers/gpio/gpiolib-acpi.c > > index 31008b0aef77..b9c3140cbd6d 100644 > > --- a/drivers/gpio/gpiolib-acpi.c > > +++ b/drivers/gpio/gpiolib-acpi.c > > @@ -1097,8 +1097,7 @@ acpi_gpio_adr_space_handler(u32 function, acpi_physical_address address, > > mutex_unlock(&achip->conn_lock); > > > > if (function == ACPI_WRITE) > > - gpiod_set_raw_value_cansleep(desc, > > - !!((1 << i) & *value)); > > + gpiod_set_raw_value_cansleep(desc, !!(*value & BIT(i))); > > Nit: Here I would use a helper variable to make it (much) more readable. > > Anyway, > > Reviewed-by: Mika Westerberg <mika.westerberg@xxxxxxxxxxxxxxx> Thank you for review of almost all patches in the series! I will try to address your comments against temporary variable in other patches, but my motivation is quite similar to yours here. -- With Best Regards, Andy Shevchenko