czw., 19 wrz 2019 o 08:10 Anson Huang <Anson.Huang@xxxxxxx> napisał(a): > > On some of i.MX SoCs like i.MX8QXP, there is ONLY one IRQ for each > GPIO bank, so it is better to check the IRQ count before getting > second IRQ to avoid below error message during probe: > > [ 1.070908] gpio-mxc 5d080000.gpio: IRQ index 1 not found > [ 1.077420] gpio-mxc 5d090000.gpio: IRQ index 1 not found > [ 1.083766] gpio-mxc 5d0a0000.gpio: IRQ index 1 not found > [ 1.090122] gpio-mxc 5d0b0000.gpio: IRQ index 1 not found > [ 1.096470] gpio-mxc 5d0c0000.gpio: IRQ index 1 not found > [ 1.102804] gpio-mxc 5d0d0000.gpio: IRQ index 1 not found > [ 1.109144] gpio-mxc 5d0e0000.gpio: IRQ index 1 not found > [ 1.115475] gpio-mxc 5d0f0000.gpio: IRQ index 1 not found > > Signed-off-by: Anson Huang <Anson.Huang@xxxxxxx> > --- > drivers/gpio/gpio-mxc.c | 12 +++++++++--- > 1 file changed, 9 insertions(+), 3 deletions(-) > > diff --git a/drivers/gpio/gpio-mxc.c b/drivers/gpio/gpio-mxc.c > index 7907a87..39ba7dd 100644 > --- a/drivers/gpio/gpio-mxc.c > +++ b/drivers/gpio/gpio-mxc.c > @@ -426,9 +426,15 @@ static int mxc_gpio_probe(struct platform_device *pdev) > if (IS_ERR(port->base)) > return PTR_ERR(port->base); > > - port->irq_high = platform_get_irq(pdev, 1); > - if (port->irq_high < 0) > - port->irq_high = 0; > + err = platform_irq_count(pdev); > + if (err < 0) > + return err; > + > + if (err > 1) { Could you use a variable called irq_count or something here? This 'err' is a confusing name for a variable that contains a valid value. Bart > + port->irq_high = platform_get_irq(pdev, 1); > + if (port->irq_high < 0) > + port->irq_high = 0; > + } > > port->irq = platform_get_irq(pdev, 0); > if (port->irq < 0) > -- > 2.7.4 >