On Thu, Sep 5, 2019 at 2:17 AM Rashmica Gupta <rashmica.g@xxxxxxxxx> wrote: > On Wed, 2019-09-04 at 19:27 +0300, Andy Shevchenko wrote: > > On Wed, Sep 4, 2019 at 9:14 AM Rashmica Gupta <rashmica.g@xxxxxxxxx> > > wrote: > > > - banks = gpio->config->nr_gpios >> 5; > > > + banks = (gpio->config->nr_gpios >> 5) + 1; > > > > Shouldn't be rather DIV_ROUND_UP(nr_gpios, sizeof(u32)) ? > > I agree that DIV_ROUND_UP is the right thing to use here, but wouldn't > it be DIV_ROUND_UP(nr_gpios, 32)? Right. Either this or BITS_PER_TYPE(u32). > > > gpio->dcache = devm_kcalloc(&pdev->dev, > > > banks, sizeof(u32), > > > GFP_KERNEL); -- With Best Regards, Andy Shevchenko