On Tue, Oct 31, 2017 at 1:27 PM, Ard Biesheuvel <ard.biesheuvel@xxxxxxxxxx> wrote: > I currently have this in my DTS: > > &gpio { > dsw3_1 { > gpios = <0 GPIO_ACTIVE_HIGH>; > gpio-hog; > input; > }; > > dsw3_2 { > gpios = <1 GPIO_ACTIVE_HIGH>; > gpio-hog; > input; > }; > > dsw3_3 { > gpios = <2 GPIO_ACTIVE_HIGH>; > gpio-hog; > input; > }; > > dsw3_4 { > gpios = <3 GPIO_ACTIVE_HIGH>; > gpio-hog; > input; > }; > > dsw3_5 { > gpios = <4 GPIO_ACTIVE_HIGH>; > gpio-hog; > input; > }; > > dsw3_6 { > gpios = <5 GPIO_ACTIVE_HIGH>; > gpio-hog; > input; > }; > > dsw3_7 { > gpios = <6 GPIO_ACTIVE_HIGH>; > gpio-hog; > input; > }; > > dsw3_8 { > gpios = <7 GPIO_ACTIVE_HIGH>; > gpio-hog; > input; > }; > > for the 8 DIP switches that are connected to GPIO lines. I have no idea how to make proper use of DIP switches really. We *could* route them as inputs using GPIO keys, but it would maybe give people the idea that it is a good idea to start prying them at runtime. If they don't have a usecase I would just leave them as this. I guess/hope they will not be used by userspace either. > So I can add the names for all the lines that have a purpose, but is > that orthogonal to hogging? Naming is orthogonal to hogging and should be a functional name for the line, preferably header name, else rail name or something else reasonable. Yours, Linus Walleij -- To unsubscribe from this list: send the line "unsubscribe linux-gpio" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html