> > > > > > > > > static int dwapb_gpio_probe(struct platform_device *pdev) { > > > > > + int i; > > > > > struct resource *res; > > > > > struct dwapb_gpio *gpio; > > > > > - struct device_node *np; > > > > > int err; > > > > > - unsigned int offs = 0; > > > > > + struct device *dev = &pdev->dev; > > > > > + struct dwapb_platform_data *pdata = dev_get_platdata(dev); > > > > > + bool is_pdata_alloc = !pdata; > > > > > > > > Please combine the int's in one line (int err, i;) and put them as > > > > the last one on this list. It looks the same to the compiler of > > > > course, but more uniform for human eyes :) > > > > > > Do you think it's a good idea? In this case I, for example, would > > > like to see int err as a separate line at the end of definition > > > block. It would be better to distinguish counters and return code storage. > > > Moreover, often counters would be unsigned int. > > > > If they are both 'int' they should be combined. If 'i' is changed to > > be an unsigned int they would be separate. > > Linus, do you have any idea about it? I think it is not a big issue. > > Since no further feedbacks, I decide to use 'unsigned int i' to align the two feedbacks, since 'i' is just a counter. And will send a new version with just this changes later. -- To unsubscribe from this list: send the line "unsubscribe linux-gpio" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html